Download ItsyRealm!

Click the download link above to download ItsyRealm for your platform.

Please keep in mind ItsyRealm is currently in alpha. There may be bugs--even game breaking bugs. If you find any, feel free to report them on the GitHub project page!

Windows users: Please note the launcher requires the .NET Framework 4.5 to run. The game also requires the latest Visual C++ runtime. These are probably installed on up-to-date Windows environments.

If that's not the right platform, or you want to download it for another one, select from the list below: